
You can use Thermo Scientific™ Standard Instrument Integration (SII) for Xcalibur™ software to acquire 
data and control a wide range of instruments via the Thermo Scientific™ Xcalibur™ data system. SII for 
Xcalibur is based on the Thermo Scientific™ Dionex™ Chromeleon™ 7 Chromatography Data System and 
uses certain key Chromeleon features. This guide provides an overview of operation when SII for Xcalibur 
is installed.

Overview

Instrument
Control

For a list of instruments supported by SII for Xcalibur, refer to SII for Xcalibur List of Supported 
Instruments, provided on the SII for Xcalibur installation medium.

When SII for Xcalibur is installed, the following options are available from Xcalibur for control (and 
monitoring) of instruments supported by SII for Xcalibur:

• Automated control from Xcalibur instrument methods (Required to run a single injection or a sequence
of injections)

Automated control requires an instrument method. The SII for Xcalibur Instrument Method Wizard
supports the creation of HPLC and IC instrument methods from within Xcalibur. These methods are
stored in the Xcalibur instrument method (a *.meth file).

• Direct control from Chromeleon ePanels (Recommended for most users)

ePanels are windows that contain controls for the most frequently used instrument properties or
commands. A typical HPLC or IC system is controlled from multiple related ePanels, known
collectively as an ePanel Set. Note that ePanels may not fully support older instruments or
nonstandard configurations.

Thermo Scientific SII for Xcalibur Quick Start Guide

Note  For access to Chromeleon features other than those required by SII for Xcalibur, you must 
purchase the appropriate licenses. Contact your local Thermo Scientific sales representative for details.

Contents

• Overview

• Starting the Software

• Equilibrating the System

• Direct Control of the System

• Automated Control of the System

• Viewing Chromatographic Data

• Troubleshooting

Document No. 065608-09 June 2022  
© 2022 Thermo Fisher Scientific Inc. 
All rights reserved. 



2

• Direct control from the Chromeleon Command window (Recommended for advanced or expert users
only)

The Command window provides access to all properties and commands for a particular instrument.
Use the window to access controls that are not available on ePanels.

Data
Acquisition
and Storage

Detector signals (including conductivity and UV absorbance) and other channel data (for example, pump 
pressure and column oven temperature) are digitally transferred from SII for Xcalibur to Xcalibur for 
permanent storage. A temporary copy of the data is stored in a Chromeleon data vault (a database of 
chromatographic data). SII for Xcalibur generates three types of temporary data:

• Chromeleon sequences

• Chromeleon audit trails

• SII for Xcalibur daily log files

Data
Processing and

Reporting

Starting the
Software

Data processing and results reporting are executed in Xcalibur as usual. For details, refer to the Xcalibur 
Help.

These startup instructions assume that you have completed installation of the analytical system software 
and hardware, including configuration of the instrument in the Chromeleon Instrument Configuration 
Manager. For instructions, refer to SII for Xcalibur Installation Guide; the Chromeleon, Xcalibur, and 
Thermo Scientific™ Foundation™ manuals; and the hardware manuals. 

 To start Xcalibur and SII for Xcalibur

1. If it is not already running, start the Chromeleon Instrument Controller Service (refer to SII for
Xcalibur Installation Guide for details).

2. Click Start > All Programs > Thermo Xcalibur > Xcalibur. The Roadmap View of the Home Page
window appears.

3. On the Status page of the Information view, click Thermo Scientific SII for Xcalibur. A simplified
version of a Chromeleon ePanel appears in the SII for Xcalibur status pane (see Figure 1).
Use this ePanel to monitor basic operating parameters (pump
flow rate, autosampler status, and so on). Clicking the Direct
Control button below the ePanel opens a standard Chromeleon
ePanel Set, which allows direct control and in-depth
monitoring of the HPLC or IC system.

Figure 1. SII for Xcalibur status pane
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Equilibrating
the System

Before starting an analysis, equilibrate the chromatography system (flush the system, turn on all 
temperature-controlled devices, monitor the pump pressure and detector signal, and so on). For details 
about the steps required to equilibrate a particular system, refer to the operator’s manual for the system.

Select one of the following methods to perform equilibration:

• Select operating commands and parameters directly from the Chromeleon ePanel Set.

• Create and run an equilibration instrument method to automate the process.

Direct Control
of the System

Direct Control
Window

Direct control of instruments is possible from the Chromeleon ePanel Set or the Chromeleon Command 
window. Both locations are accessed from the SII for Xcalibur Direct Control window.

 To open the Direct Control window

Click Direct Control in the SII for Xcalibur status pane (see Figure 1). By default, the Chromeleon ePanel 
Set appears in a maximized window (see Figure 2).

Figure 2. SII for Xcalibur Direct Control window

The Direct Control window toolbar provides access to the following commands:

• Take Control and Release Control

The instrument is usually controlled by Xcalibur. Clicking Take Control places the instrument under
user control. This is required in order to perform manual actions from an ePanel or to take over
control of the system from either Xcalibur or another user. Clicking Release Control places the system
in a neutral state until Xcalibur or a user takes control again.

Tip  ePanels are best viewed in a maximized window; this size ensures that all ePanel controls and 
readouts are visible. 
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Xcalibur automatically takes control of the instrument whenever necessary. When this happens, 
controls in the Direct Control window are disabled. 

• Command

Opens the Command window. For details, see “Control from the Command Window” on page 4.

• <ePanel Set>

− <Autogenerated> When you first start Chromeleon and connect to the instrument, Chromeleon
automatically generates an ePanel Set that is based on the current instrument configuration. For
example, if the configuration includes three modules (autosampler, pump, and detector), the
<Autogenerated> ePanel Set includes a default ePanel for each module.

If you want to assign a different ePanel Set to the instrument: On the toolbar, click the down arrow
on the <Autogenerated> button, click Manage ePanel Set, and select a different ePanel from the
ePanel Set Manager dialog box.

− Custom If you want to use a modified version of the <Autogenerated> ePanel Set, add or remove
ePanels as required, and then save the ePanel Set to a different name: On the toolbar, click the
down arrow on the <Autogenerated> button, click Save ePanel Set As, and enter the new name.

− <Last Used> When you modify an ePanel Set, Chromeleon saves the changes in an ePanel Set
called <Last Used>. Modifying an ePanel Set also modifies the <Last Used> ePanel Set for the
instrument. To reuse a custom ePanel Set and ensure that it is not overwritten by newer changes,
save it to a different name.

Control from
the ePanel Set

 To control an instrument from the ePanel Set

1. If necessary, open the Direct Control window (see Figure 2).

2. To access module-specific properties, click the corresponding tab on the ePanel Set. For example, if
you want to change the pump flow rate, click the pump tab.

3. To control an instrument function, locate the control (for example, a button, slider, or gauge) for the
command or property that you want to change. Click the button or enter the preferred property value.

4. After you click a command button or change a property value, Chromeleon checks the status of the
instrument to verify that the change can be executed:

• If there are no problems, the change is executed immediately.

• If a problem is detected, a message appears. Serious problems must be resolved before Chromeleon
will execute the change.

Control from
the Command

Window

 To control an instrument from the Command window

1. If necessary, open the Direct Control window (see Figure 2).

2. Click the Command toolbar button to display the Command window (see Figure 3).

IMPORTANT  You can use ePanels for detailed instrument monitoring during data acquisition. 
However, be careful not to take control manually and interfere with the acquisition in progress.

Note  Changes to commands and properties are recorded in the Instrument Audit Trail. To view 
the Instrument Audit Trail, click the Audit tab on the ePanel Set. 
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Figure 3. SII for Xcalibur Command window

The left pane of the Command window displays a device tree. The tree lists each module configured in 
the instrument, as well as any sub-devices associated with the module. For example, if the instrument 
includes a detector, the detector module is shown as a top-level device and each of its signals is listed as 
a sub-device below.

3. Click a module or sub-device to view its properties and commands in the right pane of the Command
window:

• The Properties tab page displays the properties available for the selected module or device, as well
as their current values. Properties that can be changed are displayed on a white background.
Read-only properties are displayed on a shaded background.

• The Commands tab page displays the commands available for the selected module or device.

4. To change a property value:

a. Click the Properties tab.

b. Click the property value and type a new value. If only predefined values are allowed, click the arrow
and select a value from the list.

5. To execute a command:

a. Click the Commands tab.

b. If the command does not require any parameters, click the button next to the command name.

c. If the command includes parameters, click the down arrow in the Parameters cell, enter values for
the parameters, and click OK. Then, click the button next to the command name.

Tip  You can filter the list of properties and commands to increase or decrease the number of 
entries. Right-click anywhere in the Command window, and then select the preferred option:

• Normal: Displays properties and commands relevant for basic operation.

• Advanced: Displays properties and commands relevant for basic and advanced operation.

• Expert: Displays all properties and commands, including additional ones relevant for expert
operation (for example, diagnostic properties).
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6. After you execute a command or change a property value, Chromeleon checks the status of the
instrument to verify that the change can be executed:

• If there are no problems, the change is executed immediately.

• If a problem is detected, a message appears. Serious problems must be resolved before Chromeleon
will execute the change.

Automated
Control of the

System

Follow the instructions here to create and edit the part of the instrument method with HPLC or IC 
instrument parameters. Create and edit mass spectrometer parameters in the Xcalibur Instrument Setup as 
usual. For details, refer to the Xcalibur Help.

Creating an
Instrument

Method

 To create an instrument method

1. From the Xcalibur Home Page window, click GoTo > Open Instrument Setup. The Instrument Setup
window appears. By default, the first page of the SII for Xcalibur Instrument Method Wizard is
displayed (see Figure 4).

Figure 4. SII for Xcalibur Instrument Method Wizard: General Settings page

2. If the instrument is being controlled by the Agilent Drivers for Chromeleon, when you launch the
Instrument Method Wizard for the first time, a message box appears (see Figure 5).

Note  Changes to commands and properties are recorded in the Instrument Audit Trail. To view 
the Instrument Audit Trail, click the Audit tab on the ePanel Set. 

Tip  If the instrument configuration does not contain a mass spectrometer, the HPLC or IC front-end 
system can be operated alone via Xcalibur and SII for Xcalibur.
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Figure 5. Thermo Scientific SII for Xcalibur message box 

a. Click OK. The Windows User Account Control dialog box appears.

b. Click Yes. This enables proper operation of the Agilent Method Editor.

3. Follow the instructions on the Instrument Method Wizard pages to select the method parameters. Be
sure to select the acquisition channels that you want to acquire and store in Xcalibur.

4. When you finish selecting parameters, click Finish. The module view of the wizard appears (see
Figure 6).

Figure 6. SII for Xcalibur Instrument Method Wizard: Module view

• In the left pane, each module in the instrument is represented by an icon. The right pane displays a
series of tab pages (similar to the Instrument Method Wizard pages) with commands for the
currently selected module. The module view is an easy way to edit the most important method
commands. For details, see “Editing an Instrument Method” on page 8.

• The left pane contains two additional icons:

− Click the Startup/Shutdown icon to view and customize parameters for standby and shutdown
modes for supported instruments. For details, see “Editing On/Off/Standby States” on page 11.

IMPORTANT  To acquire a data channel in Xcalibur, the channel must have been enabled in the 
Chromeleon Instrument Configuration Manager (refer to SII for Xcalibur Installation Guide for 
details) and data acquisition of the channel must be turned on in the HPLC or IC part of the 
instrument method.
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− Click the Script Editor icon to display a chronological list of all steps defined in the Instrument
Method Wizard. You can review and customize method parameters, line-by-line. For details, see
“Editing an Instrument Method” on page 8.

5. Click Check Method on the toolbar to have SII for Xcalibur check the HPLC or IC part of the
method for errors in syntax or semantics (logic). When the process is complete, the Method Check
Results window appears in the lower half of the Instrument Method Wizard page (see Figure 7).

The window identifies any problems that were detected. Serious problems must be resolved before
Chromeleon will execute the method.

Figure 7. SII for Xcalibur Method Check Results window 

6. Correct the problems as necessary.

7. To temporarily hide the Method Check Results window, click  on the title bar of the window. 
Click the button again to display the window.

–or–

To close the Method Check Results window, click  on the title bar.

8. Click File > Save and enter a method name. Also enter any comments that you wish to save with the
method.

Editing an
Instrument

Method

Methods are usually edited in the module view, which displays the most important module-related 
commands. However, to make the following changes, you must use the Script Editor: 

• Add commands that are not available in the module view

• Add new time steps or stages

• Create conditional statements

IMPORTANT  Some error conditions cannot be detected until data acquisition is about to start.

Note  Methods created by following the procedure above can be used as acquisition methods, 
Xcalibur Start Up methods, or Xcalibur Shut Down methods.
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• Create trigger blocks

Opening the Instrument Method

 To open the instrument method

1. From the Xcalibur Home Page window, click GoTo > Open Instrument Setup. The SII for Xcalibur
Instrument Method Wizard appears.

2. Click File > Open and select the method to edit.

3. Click Thermo Scientific in the left pane of the instrument method editor window. The embedded SII
for Xcalibur Instrument Method Editor appears in the main part of the window. By default, the
selected file appears in the module view. (This view resembles the SII for Xcalibur Instrument Method
Wizard pages.)

Editing the Instrument Method in the Module View

 To edit an instrument method in the module view

1. Click the appropriate module icon in the left pane of the SII for Xcalibur Method Wizard (see
Figure 7).

2. On each page, modify parameters as needed.

3. When you finish editing, check the file for errors (see Step 4 on page 4).

4. Click File > Save.

Editing the Instrument Method in the Script Editor View

 To edit an instrument method in the Script Editor view

1. Click  in the left pane of the SII for Xcalibur Method Wizard (see Figure 8) to display 
the method script.

Control commands in the script are subdivided into predefined sections (called stages) in which related 
commands are grouped by function (for example, instrument setup or equilibration). Stage names are 
displayed on an orange background.

Note  The Script Editor is recommended for use by advanced users only. The creation of conditional 
statements or trigger blocks is recommended for expert users only; for instructions on how to create 
them, refer to the Chromeleon Help.
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Figure 8. SII for Xcalibur Method Wizard: Script Editor view

2. Edit the method as required. The sections below describe common changes; for detailed information,
refer to the Chromeleon Help.

3. When you finish editing, check the file for errors (see Step 4 on page 4).

4. Click File > Save.

To edit the value and/or property of a command

1. Click the Value column.

2. Type a value in the box.

–or–

Click the arrow and select (click) a value from the list.

To insert a new command

1. Click the line where you want to insert the new command.

2. Click the Insert Command toolbar button.

3. Click the down arrow in the Command column of the new line to display a list of available
commands.

4. Click the required command to insert it into the table.

5. Click the Value column. To enter a value for the new command:

Type a value in the box.

–or–

Click the arrow and select (click) a value from the list.

Tip  Most editing commands on the toolbar are also available on a context menu. To access the 
context menu, right-click any line in the script.
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To delete a command

1. Click the line with the command that you want to remove.

2. Click the Delete toolbar button.

To add a comment

1. On the toolbar, click the down arrow on the Insert button and click Comment.

2. Enter your comment in the Comment column.

To delete a comment

On the toolbar, click the down arrow on the Delete button and click Comment.

To insert a new time step

1. Click the line where you want to insert the new time step.

2. Click Insert Time on the toolbar.

3. Enter a time in the Time column.

To delete a time step

1. Click the time step.

2. Click Delete Time on the toolbar.

To insert a new stage

1. Click the line where you want to insert the new stage.

2. On the toolbar, click the down arrow on the Insert Stage button and select an option.

3. Insert the commands required for the new stage.

To delete a stage

1. Click the line with the stage that you want to remove.

2. Click Delete on the toolbar.

Editing
On/Off/Standby

States

If the system will not be in operation for a while, you may want to use a Smart Standby or Smart 
Shutdown method in SII for Xcalibur to automate the process of preparing the chromatography system 
for downtime. Smart Standby and Smart Shutdown methods (if supported by the instrument) are created 
and executed automatically, based on the last method used. 

If you change a value in the instrument method, verify that the associated Smart Standby or Smart 
Shutdown method is updated accordingly. SII for Xcalibur executes the Smart Standby or Smart 
Shutdown method after the last injection or the shutdown method (whichever occurs later).

Note  A new time step can be inserted in only two locations: before an existing time step or before a 
stage.
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The Xcalibur Shut Down method (not the SmartShutdown method) runs between the last injection and 
the start of the On/Off/Standby state (see “Specifying the Post-Sequence State” on page 13). Thermo 
Fisher Scientific recommends the following options:

• Run a shutdown method when the On state is selected.

• Do not run a shutdown method when the Off or Standby state is selected.

 To edit a Standby (Smart Standby) or Off (Smart Shutdown) state

1. Open the instrument method that will run last.

2. In the left pane of the SII for Xcalibur Instrument Method Wizard, click . 

3. Click the Smart Standby or Smart Shutdown tab to display the corresponding tab page (see Figure 9).

Figure 9. SII for Xcalibur Instrument Method Wizard: Smart Standby page

4. Modify the method as required (change a parameter value, exclude a module or parameter from the
method, and so on).

Running a
Sequence

5. Click File > Save.

When SII for Xcalibur is installed, create and edit sequences in Xcalibur as usual. 

 To change the start instrument

In the Xcalibur Run Sequence dialog box, the Start Instrument is usually Thermo Scientific SII for 
Xcalibur. If necessary (for example, if an external autosampler is configured as the start instrument), 
change the setting before starting the sequence.

IMPORTANT  Before editing a Smart Standby or Smart Shutdown method, familiarize yourself 
with any relevant requirements for the front-end system and the mass spectrometer. 

Tip  To quickly restore all modified parameter values to their initial settings, click the Reset to 
Defaults button at the bottom of the tab page. To restore the value of a single parameter, 
right-click the parameter and click Reset to default on the context menu.
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1. From the Sequence Setup view of the Home Page window, click Actions > Run This Sample or
Actions > Run Sequence to open the Run Sequence dialog box (see Figure 10).

Figure 10. Xcalibur Run Sequence dialog box: Start Instrument parameter

2. Click the Change Instruments button to open the Change Instruments in Use dialog box (see
Figure 11).

Figure 11. Xcalibur Change Instruments in Use dialog box

3. In the row for the instrument that you want to use as the start instrument, click the Start Instrument
column to change the blank entry to Yes.

4. Click OK to save the changes and close the dialog box.

 To monitor samples

While a sequence is running, there are three ways to monitor samples:

• If your focus is front-end system signals and parameters, SII for Xcalibur direct control is
recommended. Click Direct Control in the SII for Xcalibur status pane (see Figure 1) to display the
Chromeleon ePanel Set.

• Otherwise, use the Xcalibur Qual Browser (recommended for viewing the mass spectrometer signal) or
the Xcalibur Real Time Plot View.

Specifying the
Post-Sequence

State

When a sequence finishes running, Xcalibur places instruments into one of three states: 

• On: Select the On option to leave the system in the On state when the current sequence is
completed. After the last injection or the shutdown method (whichever occurs later), SII for
Xcalibur will not execute any commands. Select the On option to run another sequence without
waiting.
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• Standby: Select the Standby option to place the system in the Standby state when the current
sequence is completed. After the last injection or the shutdown method (whichever occurs later),
SII for Xcalibur will execute the SmartStandby portion of the last instrument method that was
used. Select the Standby option to run another sequence with only a short delay.

• Off: Select the Off option to place the system in the Off state when the current sequence is
completed. In the Off state, power to devices in the system (such as a suppressor) is turned off.
After the last injection or the shutdown method (whichever occurs later), SII for Xcalibur will
execute the SmartShutdown portion of the last instrument method that was used.

 To manually implement the On/Standby/Off state

On the Status page of the Xcalibur Information view, right-click Thermo Scientific SII for Xcalibur and 
select either Turn Device into Standby or Turn Device Off on the context menu (see Figure 12). 

Figure 12. SII for Xcalibur Device commands context menu

Viewing
Chromato-

graphic Data

You can view the chromatographic data acquired via SII for Xcalibur in the Xcalibur Qual Browser. For 
details, refer to the Xcalibur Help.

Troubleshoot-
ing

SII for Xcalibur provides complete error notification and easy recovery (see Table 1):

• After creating or editing an instrument method, you can immediately check the method for possible
errors in the syntax or semantics, using the Check Method toolbar button in the SII for Xcalibur
Method Wizard.

• Some instrument method errors cannot be detected until data acquisition is about to start. When this
type of error occurs, an Xcalibur message box is displayed.

• If a preflight error related to an LC device driver occurs, an Xcalibur message box is displayed and the
message is logged in the Chromeleon audit trail. To view the audit trail, click the Audit tab on the
ePanel Set.

• Minor problems that occur during operation are logged in both the Chromeleon audit trail and the
Xcalibur raw data files (which can be viewed via the Xcalibur Qual Browser).

Note  The Turn Device On command is currently reserved for error recovery.
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• When an Abort error occurs, an Xcalibur message box is displayed and the sequence is aborted.

Note  If the Foundation auditing database is configured, Chromeleon error and warning messages 
are logged and viewable in both the Foundation Audit Viewer and the Chromeleon audit trail. 
The Foundation Audit Viewer limits messages to 600 characters. If a message exceeds 600 
characters, check the Chromeleon audit trail to view the entire message. 

Table 1. Error messages

Error message Remedy

Preflight check failed: <Description of 
error.>

1. Click OK on the SII for Xcalibur message bar to
dismiss the message.

2. Click Actions > Stop Analysis in Xcalibur.

3. Click Actions > Start Analysis in Xcalibur.

Note: Xcalibur will resume the sequence at the 
sample immediately after the failed sample in the 
queue. If all samples after the failed sample have the 
same type of error, consider deleting the submitted 
sequence; this is more efficient than correcting 
samples individually. 

Method validation failed Row <row 
number>.

1. Edit the method in the SII for Xcalibur Method
Wizard.

2. Click Check Method to validate the method.

Note: The sequence may contain more than one 
problem; only the first failed method is reported.

Device abort. 1. Click OK to close the Xcalibur message box.

2. Check the Chromeleon audit trail or the
Foundation Audit Viewer for an explanation of
the problem.

3. Correct the problem.

4. On the Xcalibur Status page, right-click
Thermo Scientific SII for Xcalibur and then
click Turn Device On. This restores the software
to the Ready to Download state.

5. Click Actions > Start Analysis in Xcalibur.
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Related Doc-
umentation

• For detailed information about the Chromeleon data system, refer to the Chromeleon Help:

Click Help > Thermo Scientific SII for Xcalibur Contents and Index from the Thermo Xcalibur
Instrument Setup window.

–or–

Press F1 from the Direct Control window. 

• For detailed information about the Xcalibur data system, refer to the Xcalibur Help.

Contacting Us  To contact Technical Support for Dionex products

• In the U.S. and Canada, call 1-800-532-4752.

• Outside the U.S. and Canada, call the nearest Thermo Fisher Scientific office.

Trademarks Foundation is a trademark and Chromeleon and Xcalibur are registered trademarks of Thermo Fisher 
Scientific Inc. in the United States. 

SII for Xcalibur has encountered an 
error due to one of the following issues: 
a) Chromeleon 7 framework services
may not be available. b) SII license may
not be enabled. c) Access privileges may
be set incorrectly.

Enable the Chromeleon framework services:

1. Click Start and type services.msc in the search
box. In the search results, click services.msc.

2. In the list on the right side of the Services
window, right-click the name of each
Chromeleon service and then click Start.

Enable the SII for Xcalibur license:

1. Click Start > All Programs > Thermo
Chromeleon 7 > Administration Console.

2. Click User Database, and then click the Roles
folder. Expand the name of the appropriate
Role.

3. On the License tab, select the Standard
Instrument Integration License check box.

(Continued from previous page)
SII for Xcalibur has encountered an 
error due to one of the following issues: 
a) Chromeleon 7 framework services
may not be available. b) SII license may
not be enabled. c) Access privileges may
be set incorrectly.

Specify the required access privileges:

1. Click Start > All Programs > Thermo
Chromeleon 7 > Administration Console.

2. Click User Database, and then click the Roles
folder. Expand the name of the appropriate
Role.

3. On the General tab, verify that these Privileges
are not selected: Instrument Configuration,
Modify List of Custom Formulas (under Data
Vault Basics), Export Raw File (under
Reporting), Modify Custom Formulas (under
Reporting), Archive, and Administration.

Table 1. Error messages, continued

Error message Remedy
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ACQUITY, Alliance and Waters are registered trademarks of Waters Corporation. Agilent is a 
registered trademark of Agilent Technologies.

The following are registered trademarks in the United States and possibly other countries: 
Microsoft and Windows are registered trademarks of Microsoft Corporation.

All other trademarks are the property of Thermo Fisher Scientific and its subsidiaries.




