
Revision A B51007956
© 2025 Thermo Fisher Scientific Inc.
All rights reserved.

Compound Discoverer 3.5 Reporting Quick Start Guide

The Reporting Quick Start Guide provides instructions on how to perform reporting tasks
using the Thermo Scientific™ Compound Discoverer™ software. See the following topics
for details on how to perform the tasks for reporting:

• Open a result file and select the data for the report.

• Generate a report.

• Edit a Report Template

• Preview a Resolved Report

• Export or Print a Report

NOTE : These tasks can be performed even without an active software license for
Compound Discoverer application.

Open a result
file and select

the data for
the report

The Compound Discoverer application enables you to open a result file and select the data
as per study requirement. You can also review, filter, and sort the data that you want to
include in a report. For more information about filtering and sorting the data, refer to the
Compound Discoverer tutorials, the Help.

Procedure

1. Do any one of the following to open a result file:

• From the Compound Discoverer menu bar select File > Open Result.

• On the Start Page, select the result file name in blue hypertext. 
If the Start Page is closed, select View > Start Page from the Compound
Discoverer menu bar.

• On the Job Queue page, double-click a completed run.

• On the Analysis Results page of a study, double-click a completed run or select a
completed run and then, select Open Result in the Analysis Results command bar.

The reporting menu commands and the reporting toolbar icons become available.
See Reporting menu commands.

2. Select the main table of interest and apply the appropriate filters, as the report only
uses the rows displayed.

NOTE : The report only uses the rows displayed.

3. Select View > Result Filters view to reduce the number of rows (or compounds) for
the report.

IMPORTANT : The compounds tables can contain thousands of rows. Because report
generation is limited to 2,000 pages, and for practical reasons, reduce the number of
rows to only the rows of interest by applying the appropriate filters.
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4. Save the result file to keep the sort order and filter settings.

Reporting menu
commands

The following table describes the reporting menu commands.

Create a report document from the active result file.

Create a new report template.

Edit an existing report template.

Generate a
report

You can do either of the following to generate reports that display the items of interest in a
result file:

• Use any one of the 14 reporting templates (.CDReportTemplate) available in the
application by default. See Preview and print a report from an existing report template.

– Compounds No Graphs A4

– Compounds with Graphs A4

– Compounds with Graphs and mzCloud Mirror Plot A4

– Expected Compounds No Graphs A4

– Expected Compounds with Graphs A4

– Expected Compounds per File No Graphs A4

– Expected Compounds per File with Graphs A4

– Expected Compounds with Structures No Graphs A4

– Expected Compounds with Structures with Graphs A4

– GC-EI Compounds with Structure

– GC-EI Compounds with Structure, Chrom and Spectra

– GC PCI Compounds Structures 3 Graphs Predicted Comp Rel Page Break

– GC PCI Compounds with Structure, Chrom and MS1 and MS2 Spectra

– GC PCI Compounds with Structure

• You can create one of your own custom report templates. See Create a New Report
Template.

Preview and
print a report

from an
existing report

template

You can preview and print a report by opening an existing report template.

Procedure

1. Open a result file and select the data for the report.
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2. Do any one of the following to select an existing report template:

• Select Reporting > Create Report from the menu bar.

• Select the Create Report .

The Open Report Design Template dialog box opens to the Report Templates
folder.

NOTE : To select an appropriate report template, you must know what data the report
template is designed to resolve. Typically, a report template resolves the filtered data
from one of the main tables and one or more of the graphs associated with the table.
A report template can also resolve data from one or more related tables.

3. Select the appropriate report template and select Open.

The report resolution page opens with the thumbnail pane on the left and a report
preview on the right.
The tab format for the report resolution page is as follows:

 Report Template Name
As the application resolves the data with the report template, you see a progress icon.

.
When the data is resolved, the progress icon disappears, and the application begins
rendering the report pages. The current page/estimated pages box lists the progress.
If the template contains ReportInfo items, the application does not display the rendered
pages until it has rendered all of the report pages.

4. Review the contents of the report.

• If the report still contains too many pages, consider applying one or more
additional filters to the main table and any reported related tables.

• If a red line appears in the right page margin, check the report’s print width. See
Change the print width, paper size, or page orientation.

5. On the report resolution page, select Print   in the toolbar to print the report.
The Print dialog box opens.

6. Select the appropriate printer and the page range that you want to print.

IMPORTANT : The report templates that come with the application print on A4 paper. If
you are not printing on A4 paper, change the printer setting to avoid printing errors.

7. As appropriate, change the paper type for your printer.

8. Select OK to print the report.
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Create a New
Report

Template

A report template contains the layout for the data items that you want to extract from a
result file. A report can contain the data in a selected main table and its related tables and
graphical results that are associated with the main table and related tables.

Procedure

1. Open a result file.

2. From the application menu bar, select Reporting > Create Report Template.
The Customize Report dialog box opens with the name of the current table displayed
in the Reported Table list.

3. To create a report for a different table, select the table in the list.

4. Do the following to select the information that you want to include in the report:

• Under Columns, select the checkboxes for the columns that you want to include in
the report. Clear the check boxes for the columns that you do not want to include.

• Under Graphs, select the checkboxes for the graphs that you want to include in the
report.

• Under Related Tables, select the checkboxes for the related tables and the
columns in these tables that you want to include in the report.

5. Do the following to customize the report:

• To draw a separator line above the column headers for the main table and the
selected related tables, make sure that the Draw Lines checkbox is selected
(Default:  Draw Lines).

• To indent a related table, select the checkbox for the related table in the data item
list, select the table name to highlight it in blue, and enter a value in the Indenting
box.

• To transform a table’s columns from a horizontal layout to a vertical layout, select
the table in the data item list, and then select the Transpose Data checkbox.

TIP : For each table that you want to transpose, select the table name to highlight it in
blue, and then select the Transpose Data checkbox.

6. To apply a color scheme to a table, select the table listing, and then select a color
scheme from the Color scheme list.

7. Do the following in the General settings area:

• To modify the paper size, type the first letter of the paper size in the Paper Kind list
or make a selection from the list. For example, when you type L, the application
selects Letter.

• To modify the orientation, select Portrait or Landscape from the Orientation list.

• To add a custom logo, select the browse button to the right of the Logo Image and
browse to the image file of interest.

8. Select OK to apply the settings.

The report designer page opens.
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Figure 1 Report designer page
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No. Description No. Description

1 Save As 10 Zoom

2 Preview Report 11 Selection Mode

3 Print Preview 12 Snap to Grid

4 Align Columns 13 Show Lines

5 Add Items 14 Dimension Lines

6 Delete 15 Result file's folder location and file
name

7 Logo image 16 Sizing bar with section handles

8 Textbox with object name selected 17 Report Properties

9 Image container for selected graph

9. Select Preview Report  to preview the report.

The Report Preview dialog box opens.

10. Do any one of the following:

• To continue editing the template, close the Report Preview dialog box and follow
the instructions in Change the logo image.

• To save the report template, see Save the report template with a different name .

• To export or print the report, see Export or Print a Report.
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Edit a Report
Template

The report designer page shows the items that you selected in the Customize Report dialog
box or the items in the selected report template. Some of the items appear in a container
where you can add text, images, or data graphs.

Follow these procedures as needed:

• Open an existing report template

• Change the logo image

• Change the date-and-time stamp format

• Add a data graph for a main table

• Add an mzCloud mirror plot

• Edit an item by using the mouse and keyboard

• Modify the properties of an item

• Align a column heading to its associated data field

• Transpose the data fields from columns to rows or from rows to columns

• Resize a workspace section vertically

• Add a non-data item

• Add a page break between the compounds in the main result table

• Add a column from a related table to the template

• Edit the properties of subreport columns

• Move a subreport column up to the set of main table columns

• Modify the cover page section

• Change the print width, paper size, or page orientation

• Save the report template with a different name

Open an existing
report template

Procedure

1. Do any one of the following:

• Select Reporting > Edit Report Template from the menu bar.

• Select the Edit Report Template  icon in the Toolbar.

The Open Report Design Template dialog box opens to the Report Templates
folder.

2. Select a report template and select Open.

The report designer page opens as a tabbed document. The tab format is as follows:
  Existing Report Template Name.

Change the logo
image

Procedure

1. Select the logo image (picture container).
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Figure 2 Selected picture container showing the container's handle points

The picture properties appear in the properties pane.

Figure 3 Picture properties

2. In the Data area, select Browse  to the right of the Image property. You might have
to select the row to make the browse icon appear.

The Open dialog box opens with a setting of All image files for the file type.

3. Browse to the folder where you stored the logo of interest, select the logo, and select
Open.

The selected image appears in the container.

4. Modify the Layout properties as appropriate.

Change the date-
and-time stamp

format

Procedure

1. In the PageHeader section, select the DateTimeInfo text box item.

The text box properties appear in the Properties pane.

2. In the OutPutFormat text box, select browse  icon.

The OutPutFormat dialog box opens.

3. Select an appropriate data-and-time stamp and select OK.

Add a data graph
for a main table

Procedure

1. Do any one of the following:

• Right-click the DetailSection_Main_Table_Name bar and then select Add Field >
Data Graph.
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• Select the DetailSection_Main_Table_Name bar.

2. In the toolbar, select Add Items  to open a list of data graphs and related table
selections.

3. Select an available data graph from the list.
The items in the Add Items list or Add Field menu include the data graphs and related
tables for the current main table.

NOTE : When the table columns are positioned from left to right, the data graph
appears below the table columns and to the right of any existing data graphs.

Add an mzCloud
mirror plot

You can add an mzCloud mirror plot to a Compounds table, GC CI Compounds table, or
GC EI Compounds table.

Procedure

1. Add a sub report for the mzCloud results table to the details section as follows:

a. Select the DetailSection_Main_Table_Name bar.

b. In the toolbar, select the Add Items  and select mzCloud Results > Name (or
any table columns that you want to report).

The SubReport_mzCloud_Results report appears in the DetailSection area.

2. Double‑click SubReport_mzCloud_Results.

The DetailSection mzCloud_Results area appears below the bottom toolbar.
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3. Right‑click DetailSection_mzCloud_Results and select Add Field > MS2 Spectrum.

The MS Spectrum data field appears in the detail section for the related mzCloud
Results table.

1

2

3

No. Description No. Description

1 Sub Report 3 MS2 Spectrum added

2 Details section for the mzCloud
Results

Edit an item by
using the mouse

and keyboard

Procedure

1. Select the item on the report designer page, and then modify the item as follows:

• Move the item by dragging it to a different location or by using the arrow keys on
the keyboard.

• Resize the item by dragging the container’s handle points.

Modify the
properties of an

item

Procedure

1. Select the item on the report designer page.
The properties for the selected item appear in the properties pane, at the bottom right
of the report designer page. The figure below shows the properties pane for the RT
[min] data field.
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1

2

3

No. Description No. Description

1 Number of decimal places 3 Property Dialog link

2 Data field set (RT selected)

2. Do any one of the following:

• In the properties pane, modify the properties of interest, including the size and
location of the selected item and the number of decimal places for a numeric data
field.

• Double-click the Property Dialog link to open a dialog box where you can modify
the properties.
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Align a column
heading to its

associated data
field

Procedure

1. In the Page Header section, select the column heading that you want to align with its
associated data field in the Detail Section.

The Align Columns icon becomes available.

1

2

No. Description No. Description

1 Column header (Label item) in the
Page Header section

2 Data field (TextBox item) in the
DetailSection

2. In the report designer page toolbar, select Align Columns  .

Transpose the
data fields from

columns to rows
or from rows to

columns

Procedure

1. Right-click a column heading (Label) or a column data field (TextBox) and select
Transpose Data Fields.

2. To undo the change, if necessary, right-click a column heading (Label) or a column
data field (TextBox) and select Transpose Data Fields.
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Resize a
workspace

section vertically

Procedure

1. Do any of the following:

• To enlarge a workspace section, in the sizing bar drag down the handle that is
aligned with the header of the subsequent section.

• To reduce a section, drag the handle up.

• To enlarge the Appendix section, drag it down by its bottom edge.

• To reduce this workspace section, drag the bottom edge up.

Add a non-data
item

Procedure

1. In the Section Reports pane to the right of the workspace area, select an item and drag
it to the appropriate location in a workspace section; for example, add PageBreak to
break the section to the next page.

2. In the properties pane, edit the properties of the item to add a non-data item. 

Add a page
break between
the compounds

in the main
result table

Drag the PageBreak item from the Section Reports pane to the bottom of the Detail Section
of the report template to add a page break between the compounds in the main result table.

No. Description No. Description

1 Page break in the Detail Section 2 Page break properties

Add a column
from a related

table to the
template

Procedure

1. Select the DetailSection_Main_Table_Name bar.

2. In the report designer toolbar, select Add Items  to open a list of data graphs and
related table selections.

The available items in the list include the data graphs associated with the current main
table and the related tables for the current main table.
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3. Select an available related table from the list, and then select a table column.

4. If the Detail Section is collapsed, select the expand icon to open the section.

The added table column appears at the bottom of the Detail Section (data area). The
application automatically adds a line above the column heading.

1 2 3

No. Description No. Description

1 Subreport container 3 Column heading for the related table
column

2 Line above the related table column

Edit the
properties of

subreport
columns

Procedure

1. Double-click the Subreport_Related_Table_Name container to open the subreport
editor area.

The TextBox item for the related table column appears in a separate section. The
container for the item is sized to the full page width.

2. To change the properties of the TextBox item in the Detail Section for the subreport,
select the item.

The properties for the selected item appear in the properties pane to the right of the
workspace.

3. Make changes as necessary in the properties pane or double-click the Property Dialog
link below the properties pane to open the TextBox dialog box where you can make
similar changes.
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4. To close the subreport section, select the Close Sub-Report icon in the report
designer toolbar.

Figure 4 Detail Section for the items in the subreport with the container for the ΔMass
[ppm] data item sized to the full page width

Move a
subreport

column up to the
set of main table

columns

Procedure

1. Resize the column heading container for the subreport column. Then, move it to an
appropriate location in the set of main table columns.

2. Resize the Subreport_Related_Table_Name container. Then, move it to the appropriate
location in the DetailSection.

3. In the related table’s Detail Section, resize the container for the data item.
The figure below shows a report template for the Expected Compounds per File table
with an additional column from the related Expected Features table.
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Figure 5 Column from a related table added to the reported columns

1

23

No. Description No. Description

1 Column heading for the related table
column

3 Detail Section for the related table
column with a resized container for
the data item

2 Subreport container moved to the
main table's Detail Section

Modify the cover
page section

Procedure

1. In the report template designer, select the Cover Page section.

The properties for the Cover Page section appear in the properties pane. By default,
the Visible property is set to False.

1

2
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No. Description No. Description

1 To make the cover page viisble,
select True.

2 To remove the page break, select
None.

2. Under Behavior, select True for Visible property.

3. To preview the report, select Preview Report .

By default, the cover page appears as the first page of the report.

4. (Optional) Under Data, select None for NewPage to remove the page break between
the cover page and the report items.

5. To add more information to the cover page, expand the Cover Page section by
dragging down the sizing bar handle (to the left of the Page Header section).

6. To add non-data text or images to the cover page, select an item in the Section
Reports area and drag it to the cover page section.

IMPORTANT : To add a text description, such as an explanation about the purpose of
the report, use the RichTextBox item. Do not use the TextBox item on the cover
page.

Change the print
width, paper
size, or page

orientation

Procedure

1. Select the Report Properties icon (square in the upper left corner, below the toolbar) .

The report properties appear in the properties pane.
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Figure 6 Report properties
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No. Description No. Description

1 For landscape orientation, 10.4
inches is to too wide for letter-size
paper.

3 Select the appropriate paper size for
the printer.

2 Select True for landscape. Select
False for potrait.

2. To change the print width, type an appropriate numeric value for the PrintWidth
parameter.

3. To change the page orientation, under Misc, in the IsLandscape list, select True for
Landscape or False for Portrait.

4. To change the paper size for the printer, under Misc, in the PaperKind list, select the
appropriate paper size.

5. To open the list to the paper size of interest, type the first letter or first few letters of the
paper-size name; for example, type L for Letter.

Save the report
template with a
different name

Procedure

1. In the report designer toolbar, select the Save As .

The Save Report Template As dialog box opens.

2. Select a directory folder where you want to store the report template and name the
report template.

3. Select Save.

Preview a
Resolved

Report

You can preview a completely resolved report on the report resolution page (see Generate a
report) or in the Report Print dialog box. You can preview up to five resolved pages in the
Report Preview dialog box. A red line in the right page margin indicates that the print width
is too large for the selected paper size.
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Procedure

1. Do the following to preview the report in the Report Preview dialog box:

a. In the toolbar on the report designer page, select Preview Report .

The Report Preview dialog box opens, resolves the current result file with the
current template, and displays up to five pages.

2. Do the following to preview the report in the Report Print dialog box:

a. In the report designer toolbar, select Print Report .

The Report Preview dialog box opens and resolves the current result file with the
current template. The page thumbnails pane displays all of the report pages, and
the current page box provides a page count estimate.

Export or Print
a Report

You can export or print a report either from the Report Print dialog box or the Report
Resolution page.

Procedure

1. Do the following to export a report to a file:

a. In the toolbar, select Export and select a file type from the dropdown list.

The Save As dialog box opens.

2. Select a directory folder, type a name in the file name box, and then select Save.

3. Do the following to print a report:

a. In the toolbar, select Print  to open the Print dialog box.

b. Select a printer and the page range that you want to print.

c. Select OK to print the report.

Legal notices © 2025 Thermo Fisher Scientific Inc. All rights reserved.

All trademarks are the property of Thermo Fisher Scientific and its subsidiaries unless
otherwise specified.

Disclaimer

Thermo Fisher Scientific Inc. provides this document to its customers with a product
purchase to use in the product operation. This document is copyright protected and any
reproduction of the whole or any part of this document is strictly prohibited, except with the
written authorization of Thermo Fisher Scientific Inc.
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The contents of this document are subject to change without notice. All technical
information in this document is for reference purposes only. System configurations and
specifications in this document supersede all previous information received by the
purchaser.

This document is not part of any sales contract between Thermo Fisher Scientific Inc. and a
purchaser. This document shall in no way govern or modify any Terms and Conditions of
Sale, which Terms and Conditions of Sale shall govern all conflicting information between
the two documents.

For Research Use Only. Not for use in diagnostic procedures.
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